忍者ブログ
PCメモ
PC関係のメモ、気付いたこと。 simhとChromium OSをいじって遊んでいます。 Chromium OSのカスタムビルドを配布しています。(http://chromiumosde.gozaru.jp) twitter: @zui22904336 PGP fingerprint: 45FC 0E47 A68A FA06 02FE 2BEF B72C C6E6 F9FF 1C19
Admin / Write
2017/02/27 (Mon) 22:07
Chromium OS カスタムビルドのアップデートをリリースしました。
[更新内容]

 R56-9000.91

最新版のインストールイメージは以下のページの「ダウンロード」からダウンロードしてください。

http://chromiumosde.gozaru.jp

既にインストールした方はネットワークアップデートが可能です。方法については上記サイトのChromium OSのアップデートの説明を参照してください。


既にFlash プラグインをインストールしている場合、ネットワークアップデート後は消えてしまいますので再度インストールをお願いします。

問題や動作報告などはこちらのページのコメントにお願いいたします。

拍手[1回]

PR


Comment
Name
Title
Mail
URL
Comment
Pass   Vodafone絵文字 i-mode絵文字 Ezweb絵文字
不具合の報告です
NONAME 2017/03/01(Wed)02:51:01 編集
lenovo ideapad S10-3
キーボードとタッチパッド認識しません。
USB接続すると認識します。
It works!
Takeshi 2017/03/01(Wed)05:44:33 編集
Dell Latitude D600
CPU: Pentium M 2.0Ghz
GPU: ATI Mobility FireGL 9000
RAM: 1.5 Gig
Wifi: Atheros AR2413/AR2414

不具合3つ。アルプスタッチパッドのtap-to-click, TapButton1=1, default で使えたらうれしいです。ファイルの書き換えがわからなかったので、croshより、synclient をつかって、動作ができております。

2点目、Google,その他辞書サイトの、発音ボタンがクリックしても音がなりません。MP3の再生はできます。

3点目、in 'Start up', 'Continue where you left off' is ticked and when I close the window before I shut the system off, the tabs doesn't come back.

Other than that, this OS works perfect, actually this chromium browser seems to be working smoother than a stand alone chromium on other OSes. I've shopped around for other distros for this old machine and none worked better than yours, is it because of this zram? Dunno, but you must've tweaked this build pretty good and I'm very thankful for that.

There's one more thing though. This is a minor inconvenience that I can't paste highlighted text with middle click, I was just wondering...

Lastly, I updated to this new version(R56) in a OTA manner for the first time lately, it went without a hitch. OH, and this graphic card never suspend with linux, I followed your tips and I'm doing fine. Thanks again and I'm counting on you to keep producing 32bit Chromium OS built, that works! for the foreseeable future, awesome, awesome work, bravo!
Re: 不具合の報告です
zui URL 2017/03/01(Wed)21:40:55 編集
NONAME 様

ご報告いただいた不具合の件ですが、手元に実機が無いため確実なことは申し上げられませんが、カーネルの設定を確認したところLENOVO用キーボード関連ドライバの設定が有効になっていませんでしたので、次回のリリースでこれを有効にしてビルドしてみます。実機が無いため未評価でのリリースとなり、解決をお約束できませんが、可能であればご確認いただければと思います。
Re: It works!
zui URL 2017/03/01(Wed)23:04:42 編集
Takeshi様

動作報告ありがとうございます。返信はすべて日本語にさせていただきます。

タッチパッドについては、こちらで用意しているスクリプトに問題があることがわかりましたので今後のリリースで修正いたします。
ご自分で修正したい場合はシェルから以下の手順でファイルを編集できます。

$ sudo mount -o remount,rw /
$ sudo vi /etc/X11/xorg.conf.d/40-touchpad-cmt.conf

Google翻訳の発音ボタンの件ですが、CPUがPentium M/Celeron Mの場合にChromium OSのオーディオサーバで問題が起きる模様です。今後調査を行いますが問題の解決についてはお約束できません。ご了承ください。

3番目の件は詳細設定の「起動時」−「前回開いていたページを開く」のことだと思いますが、こちらで再現を試みましたが現象を確認できませんでした。ブラウザを閉じてシャットダウン後再起動してログインすると、閉じた時点で開いていたタブが自動で開きます。こちらでは再現しないため調査は困難です。

マウスの中ボタンによるペーストは確認した限りChromebookでもできませんでした。Chromebookにない機能への対応はできません。ご了承ください。

今後もできる限りビルドを続けていきますのでよろしくお願いいたします。
SONY VAIO VGN-CR62B 動作報告です
げっぱー 2017/03/02(Thu)21:04:56 編集
げっぱーです。いつもお世話になっております。

SONY VAIO VGN-CR62B

CPU インテル Cerelon 550(2.0GHz)
RAM 2GB

R56-9000.91につきまして

・USBメモリからの起動
・R51-8172.62からネットワークアップデートの適用
・Flash Playerインストール、動作確認
・mp3/mp4(H.264)/aacコーデック mp3再生のみ確認

以上、動作確認できました。

画面解像度も正常(1280×800)になりました。どうもありがとうございます。

また、先日の 富士通 FMV-LIFEBOOK FMV-R8280 につきましても、
ネットワークアップデートでR56-9000.91を適用して正常動作を確認できました。
その際、R55の時は適用していたタッチパッドのスクリプトも、R56では適用なしの
状態で問題なく正常に使用できています。
Re: SONY VAIO VGN-CR62B 動作報告です
zui URL 2017/03/04(Sat)00:46:56 編集
げっぱー 様

動作報告ありがとうございます。
解像度が直ったようでよかったです。タッチパッドのスクリプトについては一度適用するとアップデート時に引き継がれるようになっています。
いただきました情報は別途配布サイトの方に反映いたします。
BIBLO LOOX M/D15にて
GAIN9821 2017/03/08(Wed)16:39:23 編集
R56-9000.82で同機の不具合を上げていらっしゃった方がいたので9000.91をこちらでも追試。
通常版インストーラで最適化までは問題なく進み、自動reboot。
しかし起動後のWelcome!ウインドウが出た時点で完全ハングアップしました。
マウスカーソル出ず、KB操作不可、更には電源ボタン長押しすら不可です。
ここまで完璧なハングアップは久々に出会いました。
ちょっとカーネルバグくさい雰囲気も漂いますが…うーん?
cf-w3で動作
egpon 2017/03/08(Wed)17:58:42 編集
レッツノートCF-R3で動作しました。

「Broadcom WIFIチップ用ファームウェアのインストール」
は必要でした。

また、
http://www.lwfinger.com/b43-firmware/broadcom-wl-6.30.163.46.tar.bz2
は、最初解凍せずにSDカードでセットして読み込ま
なくて、その後解凍して両方をSDカードに入れ、
念の為、有線LANでもつないでやってみたら、wifiの
電波を認識してくれました。解凍したのが良かったのか、
有線LANがよかったのかはよくわかりません。

ただし本体へOSをインストール後、なぜか初回は
wifiのSSIDを読んでくれす、再度立ち上げ直したら、
やっと、USB立ち上げのように認識してくれました。

同様の症状の方は、是非参考にしてください。

そもそも、すでに完全にゴミ箱入りして廃棄業者へ
出す予定にしていたのですが、ディスプレイは
まだ綺麗だし、スペックが低いだけで、なんだか
もったいないな、と思っていたところでした。
以前から、捨てる前にlinuxのインストールを
試したみたいと気にはしていましたが、当方には
敷居が高かったのです。

事前にpentiumMには無理、とWebで調べてあったの
ですが、このカスタム版で対応できたことは感謝です。

ただし音が出ません。まあ画面が出るだけでも
ありがたいのですが、すでにご存知のお試し方法など
あるようなら、御指南いただけますと幸いです。

とにもかくにも、まずは旧端末を復活させて
頂いてありがとうございました。
egponさんへ
GAIN9821 2017/03/08(Wed)18:38:34 編集
こちらのブログ66ページに同様の事例と対策を報告させていただいていますので、よろしければ。
>egponさんへ
egpon 2017/03/08(Wed)19:15:58 編集
早速のレスありがとうございます

ご指摘のページ拝見しました、が、すいません、
どこが確認のためだけのコマンド入力の書込で、
どこが設定変更のためのコマンド入力なのかよく
わからなくて、手当たり次第に入力しまくると、
修復困難な環境になってしまわないか心配です。

だいたいで結構ですので、どのあたりが設定変更の
あたりかご指摘頂けると幸いです。申し訳ありません。
>egponさんへ
egpon 2017/03/08(Wed)20:25:39 編集
あらためてしばらく眺めていたら、少し見えてきた
ような気がします。

それらしいところを、どうイジったのかお伝えできる
程度に少しイジって、また報告させていただきます。
Re: BIBLO LOOX M/D15にて
zui URL 2017/03/08(Wed)20:41:08 編集
GAIN9821 様

ご連絡ありがとうございます。
本件は実機が入手でき、手元の機種でも問題が発生したため現在調査を行っていますが、解決できるかどうかはまだなんとも言えない状態です。
R56にR55のカーネルを載せても問題が生じるためカーネルの問題ではない可能性が高く、現在問題を起こしているコンポーネントの特定を進めていますがまだはっきりしたことは言えません。
いずれにせよ調査には相当の時間がかかると思われます。解決できない可能性もありますのでご了承ください。
Re: cf-w3で動作
zui URL 2017/03/08(Wed)20:55:26 編集
egpon 様

動作報告ありがとうございます。

無線LANの件ですが、こちらで調査した限りでは、CF-R3のWifiチップはIntel PRO/Wireless 2915ABGというもののようです。こちらのチップはBroadcom製ではなくIntel製のため、Broadcom用の作業は必要ないはずです。
ただ、この2915ABGは配布サイトのトップページの問題点の章にある「Intel Pro/Wireless 2200の動作の安定性」で触れているチップと同じipw2200というドライバを使用します。このドライバとChromium OSの無線LAN管理ソフトウェアは相性が悪く、何度も再起動を繰り返さないとうまく認識されないことがあります。おそらくこの問題に引っかかったのではないかと推測しています。

CF-R3のSDカードリーダーは手持ちのCF-W2と同じリコー製のもので、このSDカードリーダー用のLinuxドライバは現在のところ確認できていません。そのため、申し訳ございませんがお使いの機種ではおそらくSDカードリーダーは動作していないと思います。実行されたBroadcom用のスクリプトは有線LANからファームウェアをダウンロードしてインストールしたはずです。ただ、上でも述べましたように、この操作はお使いの機種では不要な操作と思われます。お手数をお掛けして申し訳ありませんでした。

音声が再生されない件ですが(GAIN9821様フォローありがとうございます)、まず再生されようとしたデータの形式はmp3やaac形式のものでしょうか。この場合はコーデックの導入が必要になりますので、配布サイトの「mp3/mp4(H.264)/aacコーデックの追加」をご確認頂きコーデックの導入を行ってください。コーデックを導入しているのに再生ができない場合は改めてご連絡いただければと思います。
Re2: cf-w3で動作
egpon 2017/03/09(Thu)16:02:25 編集
ご指南ありがとうございます。

古くてもう動かなくも仕方がないような機種なのに、
親身にご指導頂きまして、誠に有難うございます。

コーデック導入をしたところ、最終的に削除すべき
ファイルやフォルダが作成されていたので、多分
導入には成功しているのだとは思いますが、
やはり音は出ません。youtubeの映像で試しています。

P66の部分というのは、以下のところでしょうか?

↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓

option snd_intel8x0 ac97_quirk=inv_eapd ←この行を追加

↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑

ただし、ここにたどり着くまでのコマンドが今ひとつ
わかりません。
Re3: cf-w3で動作
zui URL 2017/03/09(Thu)22:22:36 編集
egpon 様

Youtubeで音声の確認をされていて、映像が再生されるのに音だけでないのであれば、コーデックの有無にかかわらずサウンド機能が動作していない可能性があります。
可能であれば以下の手順で情報を採取いただけないでしょうか。

1.Chromium OSにログインしてCtrl+Alt+Tを押す
2. ウィンドウが開きcrosh>と表示されるのでshellと入力
3.chronos@localhost / $ と表示されるので
cras_test_client --dump_server_info
と入力
これで表示された結果をこちらに投稿いただけないでしょうか。出力された結果をマウスで選択するとはさみのマークが表示されます。それでコピーできているのでこちらに貼り付けてください。もしかするとページにおさまらないかもしれませんがスクロールでバーで上に戻して漏らさず全部選択して貼り付けてください。

あと、念の為ヘッドホンをつなげて音量を最大にして音が聞こえるかどうかもご確認いただければと思います。

なお、本件については必ずしも解決をお約束できませんので面倒なようであれば採取いただかなくても構いません。
egponnさんへ;2
GAIN9821 2017/03/10(Fri)10:08:26 編集
"VY12F/BH-W options snd_intel8x0 ac97_quirk=inv_eapd"
と題されたコメントが私の行った対応手順ですのでご参照ください。
ただし、egponさんがviをきちんと扱える方ならここまで迂遠な手段を取る必要なく、その上のzui様のコメントの手順で大丈夫です。
ただしzui様のコメントにはtypoがございまして、記述はoptionではなくoptionsから始まりますのでご注意ください。
Re:egponnさんへ;2
egpon 2017/03/10(Fri)16:22:37 編集
System Volume (0-100): 100
Capture Gain (0.00 - 22.50): 20.00dB
User muted: Not muted
Output Devices:
ID Name
10 Intel 82801DB-ICH4: Intel 82801DB-ICH4 - IEC958:0,4
5 Intel 82801DB-ICH4: Intel 82801DB-ICH4:0,0
Output Nodes:
Stable Id ID Vol Plugged L/R swapped Time Hotword Type Name
(48d5b92a) 10:0 100 yes no 1489128786 UNKNOWN (default)
(019372bb) 5:0 100 no no 0 HEADPHONE Headphone
(ee951a9e) 5:1 100 yes no 1489128786 INTERNAL_SPEAKER*Speaker
Input Devices:
ID Name
9 Intel 82801DB-ICH4: Intel 82801DB-ICH4 - ADC2:0,3
8 Intel 82801DB-ICH4: Intel 82801DB-ICH4 - MIC2 ADC:0,2
7 Intel 82801DB-ICH4: Intel 82801DB-ICH4 - MIC ADC:0,1
6 Intel 82801DB-ICH4: Intel 82801DB-ICH4:0,0
4 Post DSP Loopback
3 Post Mix Pre DSP Loopback
Input Nodes:
Stable Id ID Gain Plugged L/R swapped Time Hotword Type Name
(55dcba67) 9:0 0 yes no 1489128786 UNKNOWN (default)
(6a4d5047) 8:0 0 yes no 1489128786 UNKNOWN (default)
(eb851f96) 7:0 0 yes no 1489128786 UNKNOWN (default)
(80b89be2) 6:0 0 no no 0 MIC Mic
(aebf6bf5) 6:1 0 yes no 1489128786 INTERNAL_MIC *Internal Mic
(8c74f766) 4:0 0 yes no 0 POST_DSP_LOOPBACK Post DSP Loopback
(8a04af91) 3:0 0 yes no 0 POST_MIX_LOOPBACK Post Mix Pre DSP Loopback
Attached clients:
ID pid uid
1 7804 1000
Num active streams: 0
Last audio active time: 404, 644688669

↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑↑
取れました!ものすごい量ですw

ヘッドホンつなげましたがやはり音しません。


GAIN9821様コメントありがとうございます。

残念ながら、viエディタはそういうものが
存在するということしか知らず、それ以降の
GAIN9821様の書き込みの意味も理解できて
おりません。
どうか step by step でよろしくお願い致します

ps.このCF-R3ですが、多分、今のレッツノート
シリーズにはもうラインナップされていない?
ような小型端末で、超旧式ですが、バッテリーの
劣化もそれほど進んでいないので、ある程度復活
出来たら、シチュエーションによってはそれなりに
使えそうな気がします。少し欲が出てきました。
皆様のおかげさまです。ありがとうございます。
動作報告
haruyuki 2017/03/10(Fri)16:44:48 編集
PC:BL300TA6B
R55-8872.76では問題なく動作しましたが、R56-9000.91は言語選択画面にてハングアップor電源断します。
おそらくこのAtom N280世代のBL300,BL350,BL310,BL100は同一の結果になると思われます。
(R55-8872.76での話ですが、この機種BL300はBL350と同様にboot: chromeos-usb.A acpi_backlight=vendor の入力が必要でした。ご参考までに。)
Re:egponnさんへ;2
zui URL 2017/03/11(Sat)09:29:38 編集
egpon 様

いただいた情報を確認しましたが異常な箇所は認められませんでした。そのため、かなり大変になりますがGAIN1921様からご提案いただいているサウンドドライバのオプション変更を試していただく以外に方法はないと思います。

step by stepとのことなので手順を箇条書きでまとめました。
以下の手順のうち、shellで実行するコマンドはこちらのブログコメントでコピーして、shellウィンドウ側でタッチパッドの右ボタンをクリックすればペーストできます。

<テキストエディタのインストール>
1. Chromium OSにログイン
2.左下の○アイコンをクリック
3.ウェブストアを開く
4.左側のテキストボックスにtextと入力
5.その下の3つのラジオボタンが現れるのでアプリを選択
6.右側のアプリ一覧の先頭にText というアプリが表示されるのでCHROMEに追加をクリック

<設定ファイルのコピー>
7.Ctrl+Alt+Tを押す
8.ウィンドウが開いてcrosh>と表示されるのでshellと入力
9.chronos@localhost / $ と表示されるので以下のコマンドを実行

cp /etc/modprobe.d/alsa.conf ~/Downloads/

※あとでこのウィンドウを使うので閉じないでそのままにしておく

<設定ファイルの編集>
10.再度左下の○をクリック
11.最初にインストールしたTextを開く
12.左のメニューにあるOpenをクリック
13.ファイル選択ダイアログが表示されるので、左側の「ダウンロード」が選択されている(青字になっている)のを確認して、右の一覧にあるalsa.confを開く
14.一番最後の行に以下を追加する。

options snd_intel8x0 ac97_quirk=inv_eapd

15.左のメニューでSaveをクリックすると保存される

<設定ファイルの書き戻し>
16.先ほどの8.shellのウィンドウに戻り以下のコマンドを実行

sudo mount -o remount,rw /
Password: ←管理者パスワードを入力(デフォルトはpassword)
sudo cp ~/Downloads/alsa.conf /etc/modprobe.d/

<編集内容の確認>
17.引き続きshellから以下を実行

cat /etc/modprobe.d/alsa.conf

ファイルの内容が表示されるので最終行にTextで書き加えた内容があればOK

18.マシンをリブート

これで再度Youtubeなどを試して音がなれば成功です。
音がならない時は以下を試してください。

・shellを起動して以下のコマンドを実行
cat /sys/module/snd_intel8x0/parameters/ac97_quirk
これで#14で指定したinv_eapdが表示されるか。
(none)などの違う値が表示されるときはどこかの手順が間違っています。

・他のオプションを試す
#14でac97_quirk=の後ろに書くパラメータを以下のいずれかに変更して再度#7以降の手順を試してみてください。

hp_only
swap_hp
swap_surround
ad_sharing
alc_jack
mute_led

すべて試してもだめなら申し訳ありませんが対応はできません。ご了承ください。

なお、上記の修正内容はChromium OSのアップデートを行うと失われますので、再度同じ作業が必要になります。
面倒であれば、#15で保存するalsa.confをgoogleドライブのマイドライブにも保存しておき、アップデート後にファイルアプリなどでマイドライブからダウンロードにコピーしてから#16以降の手順を行うことで変更内容を適用できます。
Re: 動作報告
zui URL 2017/03/11(Sat)09:59:27 編集
haruyuki 様

動作報告ありがとうございます。
ご報告いただいた件ですが、このページの上の方のコメントにあるLOOX M/D15の件と同一の問題ではないかと想像しています。

LOOX M/D15の件については調査の結果R56で追加されたChromebook用ファームウェアに関する障害情報採取用のスクリプトが原因であることが判明しました。このスクリプトはChromebook向けChrome OSの公式ビルド以外では意味がないので削除しても問題ありません。本件は次回リリース時に対策を行う予定です。

あくまでもM/D15向けの対策なので確実とは言えませんが、お手元にLinuxマシンがあり、オペレーションに慣れていらっしゃるようでしたら、以下の手順でカスタムビルドR56のUSBメモリから問題のスクリプトを削除することで動作するかもしれません。

1.LinuxマシンにカスタムビルドR56のUSBメモリを装着

2.USBメモリのパーティションをマウントするための任意のマウントポイントを作る。ここでは/tmp/mntとします。

$ mkdir /tmp/mnt

3.以下のコマンドを実行する。

$ sudo mount /dev/sd?3 /tmp/mnt

ここで?はUSBメモリの装置名に合わせて書き換えてください。

4.以下のコマンドを実行してファイルを削除する。/tmp/mntは実際のマウントポイントに応じて読み替えてください。

$ sudo rm /tmp/mnt/etc/init/send-boot-mode.conf

5.USBメモリをアンマウント

$ sudo umount /tmp/mnt

これで書き換えたUSBメモリからブートすれば動作するかもしれませんのでお試しいただければと思います。
Re: BIBLO LOOX M/D15にて
zui URL 2017/03/11(Sat)10:01:10 編集
GAIN9821 様

ご報告いただいたLOOX M/D15の件ですが、このすぐ上のコメントでも書きましたが、R56で追加されたChromebook向けの障害採取スクリプトが原因と判明しました。

対策手順を上のコメントに書いていますのでご確認いただければと思います。
Re2:egponさんへ;2
egpon 2017/03/11(Sat)23:58:54 編集
zui様、誠に丁寧な解説有難うございます

おかげで最後の確認のところまで順調に操作できています。
まだ他のオプションを全部試していませんが、コツコツと
最後までやってみます。取り急ぎ御礼まで。
BIBLO LOOX M/D15にて
GAIN9821 2017/03/12(Sun)18:03:25 編集
該当ファイルの削除にて通常版インストーラ無事起動いたしました。(今まで報告していなかったのですが、この機種ではMBR版インストーラがうまく動きません)
使ってるディストリがファイラでUSBをAutomountしてしまうものばかりなので思わぬ苦戦を強いられましたが…(汗
このタイプのディストリってコンソールからはroot権限でもmountコマンドがうまく働かないんですねぇ。
しかもファイラでmountされてるとパーミッションに問題が。
そもそも/dev/の中にも/mnt/にもUSBメモリが含まれてなかったりとマウントポイントが判らずにとんだ手間を取ってしまいました。
結局ファイラの記述からディレクトリ辿ってsend-boot-mode.confを直接chmod 777してrmという無様極まりないやり方に。
現在Youtube流しっぱなしで安定度チェック中です。
Re: BIBLO LOOX M/D15にて
zui URL 2017/03/12(Sun)21:32:58 編集
GAIN9821 様

動作報告ありがとうございます。
うまく行ったようでよかったです。

MBRインストーラについては標準のものが動かない機種のためのものですので、標準インストーラが動作するM/D15については特に対応作業は行いません。ご了承ください。
Re2-2:egponさんへ;2
egpon 2017/03/13(Mon)13:30:44 編集
音の件は、候補すべての設定を確認のため2巡やってましたが、やはり無理でした。丁寧にご指南いただいたのに残念ですが、感謝しております。有難うございます。

まあしかし、いちおう音が出れば、というぐらいの必要性でしかないし、そもそも、ゴミ箱に片足(実は両足?)を突っ込んでいたような端末なので、サクサク、とまではいかなくても、実用レベルの操作感で、Web検索ができて、Ever Noteで文章作成ができるぐらいの使い道があるので、処分せずにもうちょっと使い続けようという気になりました。昔、HP200LXというモバイル端末にハマり、出来るだけ小型でしかもキーボード入力できる端末の恩恵というものを、早くから認識していましたが、最近のタッチ系端末とは別に外付けキーボードを持ち歩く気にはなれず、また、老眼がだいぶ厳しくなってきて、今は、ちょうどこのCF-R3が、当方には、気軽にカバンに入れておける、実用的な入力端末の大きさのように思います。お陰でライフスタイルの幅が広がりそうです。誠にありがとうございました。
egponさんへ;3
GAIN9821 2017/03/13(Mon)17:29:24 編集
zui様のコメント#17の
Ctl+Alt+Tからの
crosh>shell
で開いたshellでの
cat /etc/modprobe.d/alsa.conf
できちんと新たに記述した最終行は出ていますか?
また、#18での
crosh>shell
からの
cat /sys/module/snd_intel8x0/parameters/ac97_quirk

inv_eapd
を返してきますか?

細かいやり方がzui様と私で異なるので正確なアドバイスがしにくいのですが、TextでSaveした後でダウンロードフォルダ内のalsa.confをもう一度開いてみてください。
もしそれで最終行が追加されていなければパーミッション(読み書き権限)がro(読取り専用)な可能性があります。
※Textは上書きに失敗していても警告してくれないので注意が必要です。
Save(上書き保存)ではなくSave as(名前を付けて保存)を選び、出てきたフォルダウィンドウ内のalsa.confを右クリックで削除してから保存してみてください。
以降の手順はzui様のコメントの手順で。
Re:egponさんへ;3
egpon 2017/03/13(Mon)18:27:54 編集
GAIN9821様

アドバイスありがとうございます。

>cat /etc/modprobe.d/alsa.conf. できちんと新たに
>記述した最終行は出ていますか? また、#18での
>crosh>shell.
> からの
>cat /sys/module/snd_intel8x0/parameters/ac97_quirk. >で
>inv_eapd. を返してきますか?

確認できているんです。

何度もいろいろとコマンドを入れないといけない
手続きではありますが、このページからコピーして
shellのタブに移り、そこでマウスの右クリックで
簡単に長いコマンドをコピーすることができたので、
割とテキパキと試してみることが出来ることがわかり
まりた。なので、基本的に都度、quirk= 以降に、
設定変更した文字列が入っていることを確認しています。

もしかしたら、ハード側になにか操作ボタンがあるのか?
と、Webでググってみたり、あちこちボタンを押しまくって
見ましたが、結局お手上げです。ちなみにac97_quirkも
ググってオプション設定を見つけて、ご指摘いただいた
文字列のほか、ダメ元でnoneも試したりしてみました。

かなりマイナーなパーツを使っているんでしょうかね?
epgonさんへ;4
GAIN9821 2017/03/13(Mon)19:03:50 編集
お使いのマシンはスペックデータではi855チップセットですし、多分Windows上ではSoundMAXと呼ばれるAC97コーデックチップが組み合わされている筈なんですがねえ?

では、とりあえずoptionsの記述はいったん消していただいて、shellからalsamixerと言うグラフィカルミキサーを呼び出していただくのがいいと思うんですが…さて、格納されてるディレクトリどこだったかな(汗
ちょっと後で調べてみますね。
Re:egponさんへ;3
zui URL 2017/03/13(Mon)23:20:21 編集
egpon様

もうひとつだけ試せそうな方法がありましたので以下をお試しいただけないでしょうか。

シェルを起動したあとで以下のコマンドを実行してみてください。

amixer -c 0

ずらずらと表示がでて、どこか(多分最後)に以下のように出ると思います。

Simple mixer control 'External Amplifier',0 <- 'External Amplifier'を探す
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]

'External Amplifier'の欄の最後が[on]となっているようなら

amixer -c 0 set 'External Amplifier' off

最後が[off]となっているようなら

amixer -c 0 set 'External Amplifier' on

として、念のため再度

amixer -c 0

を実行して[]の中が指定した値に変っていることを確認してください。
その後Youtubeなどを試して音が鳴るかチェックしてみてください。

これでだめだとちょっと厳しいと思います。


GAIN9821様

以前お書きいただいた手順ではalsa.confをダウンロードフォルダにコピーする際に"sudo cp"を使っているためファイルのオーナーがrootになり、その結果アクセス権の問題が生じています。私がリライトした手順はこの部分をただのcpにすることでアクセス権の問題を排除して無駄な手間を省くようにしています。/etc/modprobe.dにalsa.confを書き戻すときはsudo cpである必要があります。
Re:egponさんへ;3
zui URL 2017/03/14(Tue)00:04:03 編集
egpon様

もうひとつ、GAIN9821様からご紹介いただいているalsamixerについても触れておきます。
alsamixerは先程のamixerコマンドを対話形式にしたものです。
ただ、croshから起動したshell上だと画面が崩れるようですので、以下の手順でデベロッパーコンソールを起動して使ったほうが良いようです。

1. Ctrl+Alt+F2を押す
2. localhost login: と出るので chronosと入力
3. パスワードを聞かれたら管理者パスワード(デフォルトはpassword)を入力
4. シェルプロンプトが出るので以下のコマンドを入力

alsamixer -c 0

起動すると多数の棒グラフのような項目が表示されます。各グラフの下部に調整項目の名前が出ています。一番左の<Master>はマスタボリュームです。←→キーで項目を移動できます。棒グラフがある場所は↑↓キーで音量調節ができます。先ほど私がお願いした"External Amplifier"は右方向の画面外にあるので→キーでどんどんスクロールするとExternalというものが出てきます。OOならOn、MMならOffになっています。Mキーを押すことでOOとMMを切り替えられます。
もし"External Amplifier"を試してダメだった時はこのalsamixerの画面で各項目を調整して試行錯誤すると音が出るかもしれません。ただ、External Amplifier以外の項目については今回のようなケースで有効な項目の調整ノウハウは私にはありません。申し訳ありませんがダメだった時はご自身で試行錯誤してみてください。例えばExternal Amplifier以外にもMMとなっている項目が多数あると思われるので片っ端からOOに変えていくとどこかで音が出るかもしれません。

alsamixerを終了するときはESCを押してください。

なお、デベロッパーコンソールからChromium OSのGUIセッションに戻るときはCtrl+Alt+F1を押してください。
Re: It works! (No reply necessary)
Takeshi 2017/03/14(Tue)10:34:47 編集
zui 様

Your reply was really helpful, thanks.

R56-9000.91 related Update, and some other stuff:

Youtube/html5 player stopped working, I'll be investigating this, for now I just reverted back to .82.

Suggested Touchpad modding:
$ sudo mount -o remount,rw /
$ sudo vi /etc/X11/xorg.conf.d/40-touchpad-cmt.conf

Under the conf file, by issuing
$ cat /etc/X11/xorg.conf.d/40-touchpad-cmt.conf
-----
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
-----

I already have the options there but the system doesn't seem to be reading it. I can confirm this by simply issuing '$ synclient' in shell, I'm not asking for solutions, I'm merely sharing my experience.

Okay, so I've been reading Xorg.0.log, some figures like MaxSpeed and AccelFactor are read from the cmt conf file and being applied. This makes me conclude that the synaptic driver used on this Alps touch pad doesn't have the code to recognize and adjust TapButton options, am I correct?

詳細設定の「起動時」−「前回開いていたページを開く」について。
Yes, it's odd. Come to think of it, this may not be the first time that this happened on this machine. Back in Chrome 9 or 10 days, I vaguely recall this exact problem happening, it is peculiar.

My workaround: 1. Don't close the chromium browser window, one could shut the machine down as it is, with tabs open, and the next time I get back to the browser window, most of the time, this emergency 'Restore' button appears, saying it closed improperly on the last session. 2. An extension called 'OneTab', this is optional, I find it easier to manage the open tab sessions with this than other extensions or by using bookmarks.

I'll let you know if any big issues come up in the subsequent releases.

One last note, I shouldn't have mentioned the mid-click-paste issue, and guess what? I've just found out how to paste!

How to paste into the 'crosh' terminal:

Ctrl + Shift + v, and on my machine, a right click also works.
options snd_intel8x0 ac97_quirk=inv_eapd
GAIN9821 2017/03/14(Tue)10:41:33 編集
>zui様
ああ、なるほど、そういうことでしたか。
「システム関連ファイルを弄る時はsudoで」が染みついているもので無意識にsudoしていたのですが、やらないことが良い時もあるのですね。
勉強させていただきました。
Re2:egponさんへ;3
egpon 2017/03/14(Tue)15:56:03 編集
すいません、shellが起ち上がらなくなってしまいました。
「developer」と記載があるのでいつの間にかdeveloperモードになっているのかとnomalモードへの変更操作してみたり、もちろん本体自体の立ち上げ直しもしてみましたがshellコマンドを受け付けません。以下は、Ctrl+Alt+Tを押して、shellと入力したところまでの画面です。

Loading extra module: /usr/share/crosh/custom.d/50-crosh.sh
Welcome to crosh, the Chrome OS developer shell.

If you got here by mistake, don't panic! Just close this tab and carry on.

Type 'help' for a list of commands.

If you want to customize the look/behavior, you can use the options page.
Load it by using the Ctrl+Shift+P keyboard shortcut.

crosh> shell
ERROR: unknown command: shell

英語でhelpと打て、と書いてあるようですが、打つと、

exit
Exit crosh.

help [command]
Display general help, or details for a specific command.

help_advanced
Display the help for more advanced commands, mainly used for debugging.

ping [-4] [-6] [-c count] [-i interval] [-n] [-s packetsize] [-W waittime] <destination>
Send ICMP ECHO_REQUEST packets to a network host. If <destination> is "gw"
then the next hop gateway for the default route is used.
Default is to use IPv4 [-4] rather than IPv6 [-6] addresses.

top
Run top.

御指南頂いた操作以外のコマンドは入れていないつもり
なのですが...

心当たりがあるとすれば、昨日はEZCastというDLNAアプリを入れて試したりしていました。
なにか勝手に設定を切り替えたりしているのでしょうか?
Re2:egponさんへ;3
zui URL 2017/03/15(Wed)00:00:43 編集
egpon 様

シェルが起動しなくなった件ですが、ノーマルモードへ切り替えられたのが原因と考えられます。ノーマルモードではシェルは使用できません。
croshからdevmodeコマンドを実行して再起動し、デベロッパーモードへ戻してから再度お試しください。
詳細は配布サイトの「ノーマルモードとデベロッパーモード」の記載をご確認ください。
Re3:egponさんへ;3
egpon 2017/03/15(Wed)15:50:52 編集
zui様

モード設定のご指摘有難うございました。
本来がデベロッパーモードだったのですね。
音以前に、基盤自体がぶっ壊れたのかと心配しました。
すぐ回復できてホッとしました。

ミキサーの設定の件、あらためて詳細な解説、
誠にありがとうございました。

多数の棒グラフの画面凄いです!!
これイジって音がしないようならもう終わりっ、
ていうぐらいの画面いっぱいの音量設定画面ですネ。

しかし...全部オンにして音量メいっぱいに上げても、
やっぱり、駄目でした...

もう何か、”意地でも鳴らしてやらない”という、
意思のようなものを感じます(苦笑)

GAIN9821様も有難うございました。

映像や音楽は別途大きめのタブレットで楽しんで
いますので、この端末の方は、沈思黙考しながら
”静謐な”時間を楽しむためのテキスト専用端末
として使いたいと思います。

誠にありがとうございました。
うーん。
GAIN9821 2017/03/15(Wed)17:42:43 編集
お役に立てず何とも残念です。

R55での報告の後AD1981Bについて少し調べて、データシート見てみたりもしたんですが、このコーデックチップ、回路設計の自由度が高すぎて、基板設計者の好みで仕様が決定されているようなところがありまして、ALSAコミュニティでも悩みの種なようです。
困ったものですよね。
Re3:egponさんへ;3
zui URL 2017/03/16(Thu)00:29:09 編集
egpon様

ご報告いただきありがとうございます。動作しなかったとのことで残念ですが、これ以上は厳しいと思いますので調査はここで打ち切りとさせてください。コメントミスの方は削除しておきます。
Works almost perfectly on an old HP NC6000!
tims2002 2017/03/18(Sat)12:48:59 編集
Works almost perfectly on an old HP NC6000! I will be very grateful if you could suggest how to get graphics acceleration working in Chrome://gpu, because now 'radeonfb' driver is used. Apparently, 'radeon' driver would give the needed acceleration, but I am not enough qualified to check. Thanks again. This is an awesome system for old PC!

古いHP NC6000でほぼ完璧に動作します! Chromeでグラフィックスアクセラレーションを使用する方法を提案できれば非常に感謝しています。// gpu、これは 'radeonfb'ドライバが使用されたためです。 どうやら、 'radeon'ドライバーは必要な加速を与えるだろうが、私は十分な資格を持っていない。 再度、感謝します。 これは古いPCのための素晴らしいシステムです!

CPU: Pentium M 1.6 Ghz
GPU: ATI R 300
RAM: 1 Gig
Wifi: Atheros
Graphics acceleration
tims2002 2017/03/18(Sat)12:51:25 編集
Works almost perfectly on an old HP NC6000! I will be very grateful if you could suggest how to get graphics acceleration working in Chrome://gpu, because now 'radeonfb' driver is used. Apparently, 'radeon' driver would give the needed acceleration, but I am not enough qualified to check. Thanks again. This is an awesome system for old PC!

古いHP NC6000でほぼ完璧に動作します! Chromeでグラフィックスアクセラレーションを使用する方法を提案できれば非常に感謝しています。// gpu、これは 'radeonfb'ドライバが使用されたためです。 どうやら、 'radeon'ドライバーは必要な加速を与えるだろうが、私は十分な資格を持っていない。 再度、感謝します。 これは古いPCのための素晴らしいシステムです!

CPU: Pentium M 1.6 Ghz
GPU: ATI R 300
RAM: 1 Gig
Wifi: Atheros
Re: Graphics acceleration
zui URL 2017/03/18(Sat)14:09:50 編集
tims2002 様

#回答は日本語とさせていただきます。

ご報告ありがとうございます。

radeonfbの件ですが、shell上で以下の手順を試してみてください。

$ sudo su -
Password: <- 管理者パスワード(既定値はpassword)
# mount -o remount,rw /
# echo blacklist radeonfb > /etc/modprobe.d/fbdev-blacklist.conf

これでマシンを再起動するとうまく行くかもしれません。
手持ちのThinkPad T42ではこの方法でうまく行きました。
radeonfbは今後のリリースでは最初からブラックリストに入れておく方向で検討します。
Graphics acceleration [Resoved]
tims2002 2017/03/18(Sat)22:23:08 編集
Thanks! # echo blacklist radeonfb > /etc/modprobe.d/fbdev-blacklist.conf did not work but # echo blacklist radeonfb > /etc/modprobe.d/blacklist.conf
solved the issue!!!

ありがとう! #echo blacklist radeonfb> /etc/modprobe.d/fbdev-blacklist.confは動作しませんでしたが、#echo blacklist radeonfb> /etc/modprobe.d/blacklist.conf
問題を解決しました!
動作報告
noufu 2017/03/25(Sat)17:58:26 編集
WindowsVistaのサポート終了を機に、こちらさまの最新版ビルドを導入させていただきました。無事動作しておりますのでご報告させていただきます。

機種:NEC VersaPro UltraLite タイプVC VY10A/C-3
CPU:Core2 Duo U7500 1.06 GHz
メモリ:1.5GB
GPU:Intel 945GMS Express
無線LAN: Intel Pro Wireless 3945ABG

USBメディアからのブート:OK
Wifi動作:OK
Sound:OK
HDDインストール:OK
タッチパッド動作:変更スクリプト実施後OK
Flash Playerインストール:OK

以上、まだYoutube視聴等のみの状況ですが、問題なく動作いたしました。
今後も引き続きリポートさせていただきますが、取り急ぎ御礼まで。
HOME   69  68  67  66  65  64 
プロフィール
HN:
zui
性別:
非公開
PR
忍者カウンター
忍者ブログ [PR]